Excel : Trouver le premier caractère non numérique dans une valeur de texte

(Last Updated On: 10 février 2018)

Dans bien des situations, vous avez une quantité de données dans une feuille de calcul composée de chiffres et d’autres caractères, par exemple avec des cellules contenant des valeurs comme « 22.Amortissement », et vous voulez être en mesure de déterminer la position du premier caractère non-numérique. Dans l’exemple « 22.Amortissement », vous voulez trouver la position du point « . », ici 3, qui sépare la partie numérique de la partie texte de vos valeurs.

Vous pouvez utiliser une formule matricielle pour calculer la position du premier caractère non-numérique. La formule matricielle suivante (à valider avec Ctrl + Maj + Entrée) fonctionnera dans la majorité des cas.

Formule générale

Utiliser la formule suivante :

{=EQUIV(VRAI;ESTERR(CNUM(STXT(A1;LIGNE(INDIRECT("1:"&NBCAR(A1)));1)));0)}

Si la cellule A1 est vide ou si elle contient uniquement des chiffres, la formule ci-dessus ne fonctionnera pas bien. Vous pouvez cependant tester les valeurs vides ou nulles, en ajoutant une condition SI :

{=SI( OU(A1="";A1=0) ; ""; EQUIV(VRAI;ESTERR(CNUM(STXT(A1;LIGNE(INDIRECT("1:"&NBCAR(A1)));1)));0))}

Et voilà 😉

TELECHARGER LE FICHIER D’EXEMPLE

Télécharger le classeur Excel pour ce tutoriel. Seuls votre adresse e-mail et nom vous seront demandés dans la prochaine étape. Vous recevrez le lien de téléchargement par e-mail.